$re = '/"[^"]+"|(\$[^$]*\$)/';
$str = '$Country$$Country$
WAN$Country$/$Country$
$Country$/29
$Country$/$Country$
"$fdfsrwdrdgf$1$asffdjhk"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);