using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]+""|(\$[^$]*\$)";
string input = @"$Country$$Country$
WAN$Country$/$Country$
$Country$/29
$Country$/$Country$
""$fdfsrwdrdgf$1$asffdjhk""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}