re = /"[^"]+"|(\$[^$]*\$)/
str = '$Country$$Country$
WAN$Country$/$Country$
$Country$/29
$Country$/$Country$
"$fdfsrwdrdgf$1$asffdjhk"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end