using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0\s]*|[0\s]*$";
string substitution = @"";
string input = @"0 0 1 2 3
0 -2 4 0 0 0
0 3 0 -4 0 0
0 10 9 0 0 20 0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}