import re
regex = re.compile(r"^[0\s]*|[0\s]*$", flags=re.MULTILINE)
test_str = ("0 0 1 2 3\n"
"0 -2 4 0 0 0\n"
"0 3 0 -4 0 0\n"
"0 10 9 0 0 20 0")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)