re = /^[0\s]*|[0\s]*$/m
str = '0 0 1 2 3
0 -2 4 0 0 0
0 3 0 -4 0 0
0 10 9 0 0 20 0'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result