using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<key>src|title|alt)=""(?<value>[^""]+)""\s*)+?";
string input = @"<img src=""/image/fluffybunny.jpg"" title=""Тайтл"" alt=""Деск"" />
<img src=""/image/fluffybunny.jpg"" title=""Тайтл"" alt=""Деск"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}