$re = '/(?:(?<key>src|title|alt)="(?<value>[^"]+)"\s*)+?/';
$str = '<img src="/image/fluffybunny.jpg" title="Тайтл" alt="Деск" />
<img src="/image/fluffybunny.jpg" title="Тайтл" alt="Деск" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);