package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?<key>src|title|alt)="(?<value>[^"]+)"\s*)+?`)
var str = `<img src="/image/fluffybunny.jpg" title="Тайтл" alt="Деск" />
<img src="/image/fluffybunny.jpg" title="Тайтл" alt="Деск" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}