import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<key>src|title|alt)=\"(?<value>[^\"]+)\"\\s*)+?";
final String string = "<img src=\"/image/fluffybunny.jpg\" title=\"Тайтл\" alt=\"Деск\" />\n"
+ "<img src=\"/image/fluffybunny.jpg\" title=\"Тайтл\" alt=\"Деск\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}