#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\d)\d{3}[.\s-]?\d{3}[.\s-]?\d{4}(?!\d)"
Local $sString = "18005555555" & @CRLF & _
"80055555551" & @CRLF & _
""8005555555"" & @CRLF & _
"8005555555" & @CRLF & _
"800.555.5555" & @CRLF & _
""s8005555555""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")