$re = '/(?<!\d)\d{3}[.\s-]?\d{3}[.\s-]?\d{4}(?!\d)/';
$str = '18005555555
80055555551
"8005555555"
8005555555
800.555.5555
"s8005555555"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);