use strict;
my $str = '18005555555
80055555551
"8005555555"
8005555555
800.555.5555
"s8005555555"';
my $regex = qr/(?<!\d)\d{3}[.\s-]?\d{3}[.\s-]?\d{4}(?!\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}