using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\d{3}[.\s-]?\d{3}[.\s-]?\d{4}(?!\d)";
string input = @"18005555555
80055555551
""8005555555""
8005555555
800.555.5555
""s8005555555""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}