#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)a\-?\-?p\-?p\-?l\-?e"
Local $sString = "I saw an a-pple over there" & @CRLF & _
"I saw an a-p-p-l-e over there" & @CRLF & _
"I saw an apple over there" & @CRLF & _
"I saw an appl-e over there"
Local $sSubst = "<<replacement>>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)