import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a\\-?\\-?p\\-?p\\-?l\\-?e";
final String string = "I saw an a-pple over there\n"
+ "I saw an a-p-p-l-e over there\n"
+ "I saw an apple over there\n"
+ "I saw an appl-e over there";
final String subst = "<<replacement>>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}