$re = '/a\-?\-?p\-?p\-?l\-?e/m';
$str = 'I saw an a-pple over there
I saw an a-p-p-l-e over there
I saw an apple over there
I saw an appl-e over there';
$subst = "<<replacement>>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;