const regex = /a\-?\-?p\-?p\-?l\-?e/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a\\-?\\-?p\\-?p\\-?l\\-?e', 'gm')
const str = `I saw an a-pple over there
I saw an a-p-p-l-e over there
I saw an apple over there
I saw an appl-e over there`;
const subst = `<<replacement>>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);