package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]*(?:,[0-9]{3})*\.[0-9]{2}$`)
var str = `Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don't allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}