import re
regex = re.compile(r"^[0-9]*(?:,[0-9]{3})*\.[0-9]{2}$", flags=re.MULTILINE)
test_str = ("Allow\n\n"
"100,000.12\n\n"
"10,000.12\n\n"
"1,000.12\n\n"
"100.12\n\n"
"10.12\n\n"
".12\n\n"
"Don't allow\n\n"
"abcd\n\n"
"1,,000.12\n\n"
"1,00.12\n\n"
"1,000.0\n\n"
"1,000.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")