re = /^[0-9]*(?:,[0-9]{3})*\.[0-9]{2}$/m
str = 'Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don\'t allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end