package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b((?:PRIMARY\s*?)?KEY) \(([^\)]*)\)`)
var str = `'CREATE table "msg" ( "myid" INT(10) UNSIGNED , "user" INT(10) UNSIGNED , "new_mes" SMALLINT(5) UNSIGNED , "total_mes" MEDIUMINT(8) UNSIGNED , "lastdate" DATETIME , PRIMARY KEY ("ids"), KEY ("lastdate") )'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}