// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((?:PRIMARY\s*?)?KEY) \(([^\)]*)\)").unwrap();
let string = "'CREATE table \"msg\" ( \"myid\" INT(10) UNSIGNED , \"user\" INT(10) UNSIGNED , \"new_mes\" SMALLINT(5) UNSIGNED , \"total_mes\" MEDIUMINT(8) UNSIGNED , \"lastdate\" DATETIME , PRIMARY KEY (\"ids\"), KEY (\"lastdate\") )'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}