import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:PRIMARY\\s*?)?KEY) \\(([^\\)]*)\\)";
final String string = "'CREATE table \"msg\" ( \"myid\" INT(10) UNSIGNED , \"user\" INT(10) UNSIGNED , \"new_mes\" SMALLINT(5) UNSIGNED , \"total_mes\" MEDIUMINT(8) UNSIGNED , \"lastdate\" DATETIME , PRIMARY KEY (\"ids\"), KEY (\"lastdate\") )'";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}