import re
regex = re.compile(r"\b((?:PRIMARY\s*?)?KEY) \(([^\)]*)\)", flags=re.IGNORECASE)
test_str = "'CREATE table \"msg\" ( \"myid\" INT(10) UNSIGNED , \"user\" INT(10) UNSIGNED , \"new_mes\" SMALLINT(5) UNSIGNED , \"total_mes\" MEDIUMINT(8) UNSIGNED , \"lastdate\" DATETIME , PRIMARY KEY (\"ids\"), KEY (\"lastdate\") )'"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")