# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/server\s*=\s*\Khttps?:\\/\\/(?:www\.)?/http:\/\//g;t' <<< "server=https://www.versatile-ag.ca/NA/EN/locator/locator.php"