re = /server\s*=\s*\Khttps?:\/\/(?:www\.)?/
str = 'server=https://www.versatile-ag.ca/NA/EN/locator/locator.php'
subst = 'http://'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result