use strict;
my $str = 'server=https://www.versatile-ag.ca/NA/EN/locator/locator.php';
my $regex = qr/server\s*=\s*\Khttps?:\/\/(?:www\.)?/p;
my $subst = 'http://';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";