$re = '/server\s*=\s*\Khttps?:\/\/(?:www\.)?/';
$str = 'server=https://www.versatile-ag.ca/NA/EN/locator/locator.php';
$subst = "http://";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;