re = />([^<]*?)</
str = '<div contenteditable="true">
hi</br>
This is a multiple line</br>
code
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end