import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\w:\\-() ]+)$";
final String string = "Description: Corsican\n\n\n\n\n"
+ "Description: Cree\n\n\n\n\n\n"
+ "Description: Czech\n\n\n\n\n\n"
+ "Description: Church Slavic\n"
+ "Description: Church Slavonic\n"
+ "Description: Old Bulgarian\n"
+ "Description: Old Church Slavonic\n"
+ "Description: Old Slavonic\n\n\n\n\n"
+ "Description: Chuvash\n\n\n\n\n"
+ "Description: Welsh\n\n\n\n\n\n"
+ "Description: Danish\n\n\n\n\n\n"
+ "Description: German\n\n\n\n\n\n"
+ "Description: Dhivehi\n"
+ "Description: Divehi\n"
+ "Description: Maldivian\n\n\n\n\n\n"
+ "Description: Dzongkha\n\n\n\n\n\n"
+ "Description: Ewe\n\n\n\n\n"
+ "Description: Modern Greek (1453-)\n\n\n\n\n\n"
+ "Description: English\n\n\n\n\n\n"
+ "Description: Esperanto\n\n\n\n\n\n"
+ "Description: Spanish\n"
+ "Description: Castilian\n\n\n\n\n\n"
+ "Description: Estonian\n\n\n\n\n\n\n"
+ "Description: Basque\n\n\n\n\n\n"
+ "Description: Persian";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}