# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[\w:\-() ]+)$"
test_str = ("Description: Corsican\n\n\n\n\n"
"Description: Cree\n\n\n\n\n\n"
"Description: Czech\n\n\n\n\n\n"
"Description: Church Slavic\n"
"Description: Church Slavonic\n"
"Description: Old Bulgarian\n"
"Description: Old Church Slavonic\n"
"Description: Old Slavonic\n\n\n\n\n"
"Description: Chuvash\n\n\n\n\n"
"Description: Welsh\n\n\n\n\n\n"
"Description: Danish\n\n\n\n\n\n"
"Description: German\n\n\n\n\n\n"
"Description: Dhivehi\n"
"Description: Divehi\n"
"Description: Maldivian\n\n\n\n\n\n"
"Description: Dzongkha\n\n\n\n\n\n"
"Description: Ewe\n\n\n\n\n"
"Description: Modern Greek (1453-)\n\n\n\n\n\n"
"Description: English\n\n\n\n\n\n"
"Description: Esperanto\n\n\n\n\n\n"
"Description: Spanish\n"
"Description: Castilian\n\n\n\n\n\n"
"Description: Estonian\n\n\n\n\n\n\n"
"Description: Basque\n\n\n\n\n\n"
"Description: Persian")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.