const regex = /[ACE]_.{2}:A/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ACE]_.{2}:A', '')
const str = `C_16:A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}