$re = '/[ACE]_.{2}:A/';
$str = 'C_16:A';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);