import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<===)(.*?)(?=&)";
final String string = "product_type_l1==costumes&+product_type_l2==1950s&+product_type_l3==adult&+product_type_l4==no\n"
+ "filter&+product_type_l5==female&+id=fun2502bl-m";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}