re = /(?<===)(.*?)(?=&)/
str = 'product_type_l1==costumes&+product_type_l2==1950s&+product_type_l3==adult&+product_type_l4==no
filter&+product_type_l5==female&+id=fun2502bl-m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end