const regex = /(?<===)(.*?)(?=&)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<===)(.*?)(?=&)', 'gs')
const str = `product_type_l1==costumes&+product_type_l2==1950s&+product_type_l3==adult&+product_type_l4==no
filter&+product_type_l5==female&+id=fun2502bl-m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}