import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*[.,]?\\d*$";
final String string = "1\n"
+ "123\n"
+ "123.\n"
+ "123.4\n"
+ "123.456\n"
+ ".456\n"
+ "123,\n"
+ "123,4\n"
+ "123,456\n"
+ ",456\n"
+ "0.,1\n"
+ "0a,1\n"
+ "0..1\n"
+ "1.1.2\n"
+ "100,000.99\n"
+ "100.000,99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}