import re
regex = re.compile(r"^\d*[.,]?\d*$", flags=re.MULTILINE)
test_str = ("1\n"
"123\n"
"123.\n"
"123.4\n"
"123.456\n"
".456\n"
"123,\n"
"123,4\n"
"123,456\n"
",456\n"
"0.,1\n"
"0a,1\n"
"0..1\n"
"1.1.2\n"
"100,000.99\n"
"100.000,99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")