re = /^\d*[.,]?\d*$/m
str = '1
123
123.
123.4
123.456
.456
123,
123,4
123,456
,456
0.,1
0a,1
0..1
1.1.2
100,000.99
100.000,99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end