// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d*[.,]?\d*$").unwrap();
let string = "1
123
123.
123.4
123.456
.456
123,
123,4
123,456
,456
0.,1
0a,1
0..1
1.1.2
100,000.99
100.000,99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}