import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*SEC_LOGIN-\\d-LOGIN_\\w+: Login (?P<Cisco_SEC_LOGIN_Result>[^\\s]+) \\[user: (?P<Cisco_SEC_LOGIN_User>[^\\s]*)\\] \\[Source: (?P<Cisco_SEC_LOGIN_SrcIP>[^\\]]+)\\] .+";
final String string = "Nov 24 17:21:03 192.168.77.254/192.168.77.254 132162: Nov 24 2016 17:21:02: %SEC_LOGIN-5-LOGIN_SUCCESS: Login Success [user: ] [Source: 192.168.77.20] [localport: 23] at 17:21:02 CST Thu Nov 24 2016";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}