import re
regex = re.compile(r"^.*SEC_LOGIN-\d-LOGIN_\w+: Login (?P<Cisco_SEC_LOGIN_Result>[^\s]+) \[user: (?P<Cisco_SEC_LOGIN_User>[^\s]*)\] \[Source: (?P<Cisco_SEC_LOGIN_SrcIP>[^\]]+)\] .+")
test_str = "Nov 24 17:21:03 192.168.77.254/192.168.77.254 132162: Nov 24 2016 17:21:02: %SEC_LOGIN-5-LOGIN_SUCCESS: Login Success [user: ] [Source: 192.168.77.20] [localport: 23] at 17:21:02 CST Thu Nov 24 2016"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")