const regex = new RegExp('^.*SEC_LOGIN-\\d-LOGIN_\\w+: Login (?P<Cisco_SEC_LOGIN_Result>[^\\s]+) \\[user: (?P<Cisco_SEC_LOGIN_User>[^\\s]*)\\] \\[Source: (?P<Cisco_SEC_LOGIN_SrcIP>[^\\]]+)\\] .+', 'g')
const str = `Nov 24 17:21:03 192.168.77.254/192.168.77.254 132162: Nov 24 2016 17:21:02: %SEC_LOGIN-5-LOGIN_SUCCESS: Login Success [user: ] [Source: 192.168.77.20] [localport: 23] at 17:21:02 CST Thu Nov 24 2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}