$re = '/^.*SEC_LOGIN-\d-LOGIN_\w+: Login (?P<Cisco_SEC_LOGIN_Result>[^\s]+) \[user: (?P<Cisco_SEC_LOGIN_User>[^\s]*)\] \[Source: (?P<Cisco_SEC_LOGIN_SrcIP>[^\]]+)\] .+/';
$str = 'Nov 24 17:21:03 192.168.77.254/192.168.77.254 132162: Nov 24 2016 17:21:02: %SEC_LOGIN-5-LOGIN_SUCCESS: Login Success [user: ] [Source: 192.168.77.20] [localport: 23] at 17:21:02 CST Thu Nov 24 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);