using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<th>City :</th>.*?<td>(.*?)</td>";
string input = @" <tr>
<th>postal code :</th>
<td>75012</td>
</tr>
<tr>
<th>City :</th>
<td>Paris</td>
</tr>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}