const regex = new RegExp('<th>City :</th>.*?<td>(.*?)</td>', 'sg')
const str = ` <tr>
<th>postal code :</th>
<td>75012</td>
</tr>
<tr>
<th>City :</th>
<td>Paris</td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}