$re = '~<th>City :</th>.*?<td>(.*?)</td>~s';
$str = ' <tr>
<th>postal code :</th>
<td>75012</td>
</tr>
<tr>
<th>City :</th>
<td>Paris</td>
</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);