// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<th>City :</th>.*?<td>(.*?)</td>").unwrap();
let string = " <tr>
<th>postal code :</th>
<td>75012</td>
</tr>
<tr>
<th>City :</th>
<td>Paris</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}