import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([ ]*)([a-zA-Z]\\S*)[ ]+(([a-zA-Z])([^\\r\\n\\t\\f\\v ;]*));.*";
final String string = " CostSheetNodeId nodeId;\n"
+ " ItemId itemId;\n\n"
+ " PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316";
final String subst = "\\1public \\2 parm\\U\\4\\E\\5(\\2 _\\3 = \\3)\\n\\1{\\n\\1 _\\3 = \\3;\\n\\1 return \\3;\\n\\1}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}